Windows Vista Problems WITH Solutions

Discussion in 'Trek Gaming' started by daedalus5, Nov 25, 2007.

  1. anthonyjmf

    anthonyjmf Cadet Newbie

    Aug 29, 2009
    Dublin, Ireland

    I'm trying to load New Worlds onto my vista home edition but get error message on starting the game citing some C++ error of some sort.

    How did you get Star Trek New Worlds running on your vista?

    Cheers, much appreciate response asap so i can get trekking!
  2. anthonyjmf

    anthonyjmf Cadet Newbie

    Aug 29, 2009
    Dublin, Ireland
    Hi Athanis, Just read your postings, t'is unfortunate the C++ patch didn't work, would seem windows 7 most prudent if not expensive solution. I've new worlds since it was first released, great game, almost finished it on federation mode then got distracted with uni! now am determined to finally finish it! i've been battling to install it on my vista home edition for over a week now, and nothing seems to work. let me know how your windows 98 installation goes.


  3. AthanisTree

    AthanisTree Lieutenant Junior Grade Red Shirt

    Apr 25, 2009
    Belfast, Northern Ireland
    A brisk, vaguely amusing Install of Windows 98 in Microsoft Virtual PC 2007 + Fresh install of New Worlds, update to Direct X 7 and....

    The same, sodding message.

    The project isn't a waste of time for other reasons (Boot it up just to get the classic Win98 chime :rommie: ) but..

    GRRR! Hulk want game work!

    Haven't any further ideas for you antonyjmf... Besides smacking Microsoft with a Bat'Leth. Any luck on your end?

    Oh and.. does anyone else have any Deuterium for the New Worlds MAKE-IT-WORK!! fire?
  4. anthonyjmf

    anthonyjmf Cadet Newbie

    Aug 29, 2009
    Dublin, Ireland
    Problem solved as follows:

    1. Vista installs conventionally using NTFS file system.
    2. STNW was designed to run on win 95/98 architecture using FAT32 file system.
    3. Saving any files wanted to external USB drive first, repartition you hard drive. To repartition go to "computer management (local)" then click "storage" then click "disk management" or just type "using disk managementin" in help menu and click link directly to it.
    4. Delete your existing drive ...yes delete, so ensure step 3 is complete first!
    5. Now create a new partition (D drive) and set its size to 4Gb (maximum FAT32 will operate in) and format using FAT32 option (from drop down menu);
    6. Set the remaining partition to your main partition (C drive) using NFTS on which your VISTA or XP is installed and set as active partition.
    7. FINALLY, install STNW onto the FAT32 partition (D drive).
    8. Go to folder for STNW in D drive, right click the STNW exe file, set compatibility to WINDOWS 2000 and to run as administrator, new create short cut, place on desktop, and your in :-)

    Any folks that this helps can buy me a pint next time your in Dublin!!!


  5. Deks

    Deks Rear Admiral Rear Admiral

    Oct 16, 2003
    Or ... wouldn't it be simpler to try and install ST New worlds on a USB pen drive (of say 4GB's) which was formated to FAT32 instead of re-formatting your much larger HDD partition?

    One more thing.
    Star Trek Armada 1 and 2 seem to be having problems with systems over 2GB of RAM.
    I recently tried to run Armada 1 (patched with 1.2 v) with the Millenium mod, and ran into a problem of the progress bar not moving at all when trying to start a Single Player mission (this issue was reported even without any mods installed).
    Granted, I have 4Gb Ram and a Win7 x64 Ultimate OS.
    Am trying right now to compensate for this this issue with the msconfig manipulation and setting the RAM to 2GB.
    Hopefully this will limit the OS recognizing only 2GB of RAM and ultimately the game itself.
    I'll report back soon.

    EDIT :

    Well actually, only Armada 1 has issues on systems with over 2GB of RAM.
    Armada 2 runs fine on my system (though it requires compatibility mode with XP SP2 apparently in order to avoid the 50MB memory error).

    I just opened msconfig.ini and forced windows to utilized only 1 cpu and 1.5GB of RAM.
    Upon next restart, my OS still detected 4GB of RAM, however, it stated that only 1.5GB was usable.
    And seeing the Task Manager 'Performance' tab showing only 1 CPU along with 1.5GB RAM was quite interesting - bordering on amusing.

    But Armada 1 resumed with it's blinking during the attempt to start a single player campaign and of course ultimately stopped responding.

    It would appear the only viable solution is to remove 1 of the RAM sticks and test the game like that, because the OS was still able to detect 4GB (but only use 1.5GB).
    So we are in the ballpark of the game detecting the amount of total RAM (and not just usable RAM).

    The only other solution without removing the RAM stick of course would involve using a Virtual Machine with Windows XP for example (32bit) and ordering the VM to limit RAM detection and use to say 1.5 or 2GB, and run older games like that.

    I'll try to find alternative options under Windows 7 x64 (and likely x86 users) for those of us who have 4GB of RAM so we don't have to resort to removal of the RAM sticks or VM.

    Though I have to admit that the initial idea was valid.
    It still might be ... I just have to find a way to prohibit Windows from detecting the unusable RAM.

    EDIT II:

    Forget Virtual Windows setup.It can't run games such as Armada.
    The gpu emulation is set automatically to S3 ... and that is of 0 use to us in this situation.
    If anyone else has any ideas on running Armada 2 on a system with 4GB of RAM, let me know.
    Last edited: Nov 14, 2009
  6. FishDS9

    FishDS9 Lieutenant Commander Red Shirt

    Mar 5, 2003
    Lexington, KY
    Would love to know how to get STV: EF1 to run on Win 7 pro 64bit. MajorTork is about to release a new TOS mod and I need to get this working. Help?
  7. Deks

    Deks Rear Admiral Rear Admiral

    Oct 16, 2003
    Elite Force 1 works on my system with Win 7 x64

    I ran it's Setup file with administrator priviledges.
    It took about 10 to 20 mins (or more) until I actually got to the Installation screen, but it worked.

    You just have to wait until the installation screen comes up (if that's your issue with the game).
  8. Mr. X

    Mr. X Cadet Newbie

    Dec 21, 2009
    Hi there,

    I'm new on this forum but I hope you can help me with this problem:
    I have seen the topic starter has 'Starship creator' 1 and 2 on his Vista installation and it seems to be working. I have Ship creator 1 under Windows 7 x64. And I have this script and Quicktime error (even when I configure compatibility modes and all that jazz) but to no avail. :(
    I am reluctant to install Quicktime 3 that comes with it since Win7 is superior in everyfield Quicktime 3 offers. Is it a wise decision?

  9. LenaMarie

    LenaMarie Ensign Red Shirt

    Dec 27, 2009
    About Starship Creator, yeah you dont want to install quicktime from the discs on a modern computer, i found that out the hard way and it messed it all up.

    Its better to use something called Virtual PC by Microsoft to run it.

    Im wondering if anyone can help me, I have Windows 7 Pro and a Geforce GTX 275 Video card and I cant play DS9: Fallen Okay I can, it installs fine and loads up fine, my problem is Im stuck with only Software rendering, it doesn't recognize my video card at all. Its virtually unplayable when it looks much worse then it did on the day i got it. Any idea how I can get 3D acceleration going on?
  10. Mr. X

    Mr. X Cadet Newbie

    Dec 21, 2009
    Thanks LenaMarie but I just found the solution to fix the problem, I thought I share it with you. :)

    Here goes:
    What I did was I installed Quicktime 6. 6 Also has the missing files. After installation I deleted the key programs but let the .dll's and other components that drive the extentions of the files needed for Starship Creator. It didn't interfere with the operating system (Win7) and solved the problem. It has still a scripting error of some sort but that is just one dialog that can be clicked away and everything works just fine. :D

    So long story short:
    Install Quicktime 6, uninstall Quicktime 6 but only the programs associated with it, not the mix and filter files. ;)

    I hope this works for everyone with the same problem. :)

    Edit: Wow, I just read my own post in my head with LaForge's voice and it just sounded cool. :D
  11. LenaMarie

    LenaMarie Ensign Red Shirt

    Dec 27, 2009
    Thanks, Im not sure why i had a problem with it but it broke my Quicktime and Itunes and applications that use it like Second Life, even after i uninstalled it.

    But since I have Windows XP mode with Windows 7, its easier to just use that, it plays all the SCs, Captains Chair and TNG Technical Manual nicely.

    As for 64 bit Windows 7, I've found it plays more Star Trek games then Vista did, like Klingon Honor Guard is finally playable after all these years (it didnt work on Vista at all for me) it just has framerate issues. Also Away Team works nicely, same with Aramda 2. Ds9 Fallen would work too if i could just get the renderer changed to 3D Hardware, Software looks bad. And with Dosbox I have AFU, Harbinger, 25th and JR all working perfectly.

    So far the only games i cant get to work at all are
    Dominion Wars
    New Worlds
  12. Mr. X

    Mr. X Cadet Newbie

    Dec 21, 2009
  13. LenaMarie

    LenaMarie Ensign Red Shirt

    Dec 27, 2009
    I've tried compatibility options and that patch but unfortunately Fallen seems to only want me to use Software Rendering. Its not that the Game doesnt work per-se, its just that it looks worse then a Playstation 1 game so I want to be able to switch it to use 3D Rendering, however they dont list any other options.

    I'd like to add I can confirm Starfleet Academy seems to work fine on Windows 7 as well, the only issue is mouse lag, other wise it runs perfectly.
  14. abacero

    abacero Cadet Newbie

    Jan 10, 2010
    Hi! I just joined the Forun. This information is great, however I have a problem: I am trying to use DS9-Harbinger, and I followed the guide here, but I can not find de .INI file or anywhere where the game path is located. I mounted the CD drive and the Windows drive (c:) to DOSbox. Even though DOSbox can read perfecly both drives, the game does not and when I star the game, it sends a message taht there is no CD pn drive1. I have a Compaq Presario F756 with:
    Proccesor: AMD turion 64x2
    NVidia graphics card
    Windows Vista Home Premium 32

    What can I do?

    Best regards,

  15. Woulfe

    Woulfe Commodore Commodore

    Feb 18, 2005
    3rd Rock From The Sun
    Might need to start a new thread called.....

    Windows 7 Problems With Solutions.....

    Unless everything works under 7 without any issues at all.....

  16. Eric Cheung

    Eric Cheung Fleet Captain Fleet Captain

    Jun 19, 2008
    Boston, MA
    My problem seems to be when I'm in setup, the game wants to write to the DOSBox's Z: drive. It doesn't give me any other option. Of course it says that the Z: drive has 0MB available.
  17. MANT!

    MANT! Rear Admiral Rear Admiral

    Mar 14, 2005
    in Atomo-vision
    J. I need to run a batchfile to properly load the Starbase 11 mod in EF1

    I have the following system..

    Dell Inspiron 570
    AMD Athlon II X2 240 Processor
    4 Gig Ram
    Integrated Graphics ATI ® Radeon ® HD 4200
    Windows 7 Home Premium

    Compatibility mode is no help..

    So how does one get batchfile to run under Windows 7?
  18. gigantibyte

    gigantibyte Ensign Newbie

    Dec 19, 2008
    Well this thread is a bit old, and I have Vista with SP2. ST:Hidden Evil still does not work. The only way I could get the game to run was to build a Windows 98 machine wtih DirectX 7. In fact, I can't find anyone who has been able to get this game to run on a modern machine with XP, Vista, or even Linux with Wine or Cedega.

    Unfortunately programs like VMware and Virtualbox won't likely be supporting DirectX 7 anytime soon. I even tried the program DXTweaker to add support for 7 but had no success.

    Anyone else have better luck? :(
  19. Carbonite2008

    Carbonite2008 Cadet Newbie

    Aug 24, 2010
    I bought a copy of bridge commander for my laptop but it stops installing at 3% saying the files couldn't be copied, and I'm on vista. Anyone know how I get it to work?
  20. Jax

    Jax Admiral Admiral

    Jun 21, 2003
    Waiting for Entropy
    Does Star Trek Voyager Elite Force work on Vista 32? I would love to play this game again.

    Also STBC installed on vista but I can't seem to make it work just get black screen and a soun, which sounds like an error but no msg is displayed.
    Last edited: Sep 7, 2010