Star Trek on bluray

Discussion in 'Star Trek - Original Series' started by The Caprican, Jan 4, 2012.

  1. Noname Given

    Noname Given Vice Admiral Admiral

    Joined:
    May 22, 2001
    Location:
    None Given
    Funny - doesn't do it on the two Sony Blu-Ray players I own and watch it on - guess I must be blind, eh?
     
  2. Ssosmcin

    Ssosmcin Rear Admiral Rear Admiral

    Joined:
    Sep 2, 2002
    Location:
    ssosmcin
    It depends on the brand. On my Playstation 3, it never happens, On my Magnavox it does.
     
  3. Ovation

    Ovation Vice Admiral Admiral

    To OP: Which brand and models are the players specifically?
     
  4. BillJ

    BillJ Admiral Admiral

    Joined:
    Jan 30, 2001
    Location:
    alt.nerd.obsessive.pic
    I have the PS3 and a Magnavox player I bought in 2009 and have the same results.
     
  5. Haggis and tatties

    Haggis and tatties Rear Admiral Rear Admiral

    Joined:
    Dec 27, 2002
    Location:
    Glasgow
    Scroll the ps3 dashboard all the way left to settings, then scroll all the way down to network, click internet connection, click disable.

    Taaadaaa!. :)
     
  6. ATimson

    ATimson Rear Admiral Rear Admiral

    Joined:
    Jan 3, 2003
    Location:
    Andrew Timson
    Season 3 is indeed slimmer (it came with one fewer disc). But mine did have a slipcase when I bought it at launch. :wtf:
     
  7. Ovation

    Ovation Vice Admiral Admiral

    Amazon is hit or miss with slipcases, in my experience.

    My TOS collection is in three sets but four formats. Seasons 2 and 3 are Blu-ray, season 1 is HD DVD on one side and DVD on the other. The season packaging is more elaborate but less practical.
     
  8. JimZipCode

    JimZipCode Lieutenant Commander Red Shirt

    Joined:
    Aug 13, 2010
    Does anyone else have the problem with the season 1 Blu-ray, that the sound balance is off? The music is super-loud, the dialogue is very quiet? I wind up cranking up the volume to hear lines of dialogue, than frantically dialing it way down when the music swells.

    It's actually terrible. Really interferes with watching the episodes.
     
  9. Haggis and tatties

    Haggis and tatties Rear Admiral Rear Admiral

    Joined:
    Dec 27, 2002
    Location:
    Glasgow
    Does your Tv have that auto volume thing.....if so make sure its on.....that might help.

    Or try a diffrent sound setting, i use clear voice as my Tv sound setting.

    I am of course assuming your just using the TV for sound, and not some amped separate sound system.
     
  10. Ovation

    Ovation Vice Admiral Admiral

    If you are using a home cinema receiver (and it's less than 10 years old), there should be a setting for dynamic range compression or something similar. Set it to maximum.

    Another thing to try is selecting the original 2.0 mono setting for audio rather than the default DTS HD-MA 7.1 audio. The DTS audio has a lot more dynamic range than the original audio and could easily cause your problem if you are relying on a TV speaker set, especially if it is a flat panel hi-def set.
     

Share This Page