I'm having an issue with my PC can anyone help?

Discussion in 'Science and Technology' started by Hartzilla2007, Apr 4, 2014.

  1. Hartzilla2007

    Hartzilla2007 Vice Admiral Admiral

    Joined:
    Jul 15, 2006
    Location:
    Star Trekkin Across the universe.
    I don't know if this is the right place to ask but for the last few weeks ever since my internet temporarily cut out, on my PC I've had trouble getting some long youtube videos that are taking a while to buffer and when I try to play some online games like Star Trek online either it doesn't want to start up or I get hit with a server is not responding error.

    I was wondering if anyone here had any idea what it could be and what I can do to fix it?
     
  2. Coloratura

    Coloratura Snuggle Princess Premium Member

    Joined:
    Dec 25, 2002
    Location:
    Ohio, USA
    I'm going to need a few more details. If you can, I want you to visit these websites, and then copy and paste the results here. You can do that by choosing "Share This Result" for Speedtest, and "Forum Link" for Pingtest.

    Speedtest.net

    Pingtest.net

    From there, we can begin diagnosing whether the problem is on your end, or on your ISP's end.
     
  3. Hartzilla2007

    Hartzilla2007 Vice Admiral Admiral

    Joined:
    Jul 15, 2006
    Location:
    Star Trekkin Across the universe.
    It actually seems to be working right again after I ran a maintenance program that cleared up some stuff.

    But thanks for the help anyway.
     
  4. Coloratura

    Coloratura Snuggle Princess Premium Member

    Joined:
    Dec 25, 2002
    Location:
    Ohio, USA
    Oh, okay!