Hallmark 2013 Kelvin Christmas Ornament question(s)...

Discussion in 'General Trek Discussion' started by bryce, Dec 18, 2013.

  1. bryce

    bryce Rear Admiral Rear Admiral

    Joined:
    Mar 22, 2004
    Location:
    bryce
    I just bought one of these, it was the 2nd to the last one in the store still in a box (and that one had a very noticable paint defect) but I didn't test it out until I got home, and I didn't play with the display model first (like I did before a few weeks ago.) And I wanna make sure mine still works, or if I need to find another Hallmark that *hopefully* might still have one...lol...(or try to trade it for the floor model!)

    (I would just go back to the store - or another - but I have no car so it means a LONG bus ride to any Hallmark - after calling around to find one that might still have the ornament in stock - I would have bought it earlier, but I was in the hospital.)

    Questions:

    1. Is it supposed to make any noises. I though I remembered the floor model did - but I may have imagined it.

    2. That strip on the bottom of the saucer section doesn't light up, does it? It's looks just like black paint, but I thought I remembered a light - but again, I am probaby imagining it.

    3. Tiny defects in these are unavoidable, aren't they? I looked at mine up close when I got home last night, and the engineeringing section was glued down but there's a slight slant to on side...like it was press down to dry in proper place on one side, but the other it wasn't, and there is a *tiny* line where you can see that it wasn't glued in *quite* straight...but I figure I am obsessing over nothing, and even if I find another...it's will have some other flaw.

    Plus, maybe this is a common flaw, and those of you who bought the ornaments may have noticed it too..so I wanted to ask.

    Is this something that YOU would take it back over...? I mean, it's just a Christmas tree ornament - but then again, it's cost like $36!!!!

    (I know I am obsessing a bit - I have OCD...so I do this...)
     
  2. bryce

    bryce Rear Admiral Rear Admiral

    Joined:
    Mar 22, 2004
    Location:
    bryce
    No one?

    Am I too obsessive? (Probably.)
     
  3. Finn

    Finn Vice Admiral Admiral

    Joined:
    Mar 30, 2006
    Location:
    Finn
    ^only an hour and 25 min passed between your posts. Be patient :)

    I've seen those but I don't recall any issues
     
  4. Avro Arrow

    Avro Arrow Commodore Commodore

    Joined:
    Jan 10, 2003
    Location:
    In Diefenbaker's Nightmares
    The Kelvin ornament does not make any sounds.

    I'll be honest, I haven't actually put the batteries in mine, because I don't normally bother with the light-up feature. But judging by this YouTube video, the strip you refer to does not light up.

    Probably. :)

    I don't notice that particular flaw on mine. (But TBH if it was really small, I just might not be able to see it properly.)

    Me? Probably not. But it's really up to you... it's your money, so you have to do what will make you happy. And although I probably wouldn't personally return the ornament for the flaw you described, I have exchanged other things in the past for minor issues that bugged me that other people probably would think were nothing! ;)

    HTH
     
  5. bbailey861

    bbailey861 Admiral Premium Member

    Joined:
    Oct 14, 2009
    Location:
    Kingston, ON
    I won't know the answers to your questions until Dec 25th. I am fully expecting Santa to deposit the three new ornaments into my stocking.:bolian:
     
  6. PicardSpeedo

    PicardSpeedo Lieutenant Commander Red Shirt

    Joined:
    Dec 2, 2013
    Keep a fire extinguisher handy. I had a Voyager ornament that caught fire on both warp nacelles at the same time (not joking).
     
  7. Richard Baker

    Richard Baker Fleet Captain Fleet Captain

    Joined:
    Nov 11, 2008
    Location:
    Warrior, AL
    Mine has been working fine for years- I think your Voyager had a bad starboard power coupling...
     
  8. Push The Button

    Push The Button Fleet Captain Fleet Captain

    Joined:
    Feb 21, 2013
    Location:
    Smithfield, Rhode Island USA
    Was it too close to your Borg Cube ornament?
     
  9. PicardSpeedo

    PicardSpeedo Lieutenant Commander Red Shirt

    Joined:
    Dec 2, 2013
    No, I think Deanna Troi was at the helm...