The Trek BBS

The Trek BBS (http://www.trekbbs.com/index.php)
-   Science and Technology (http://www.trekbbs.com/forumdisplay.php?f=36)
-   -   Question Mark in a Diamond -- WTF? (http://www.trekbbs.com/showthread.php?t=204253)

scotpens February 23 2013 02:27 AM

Question Mark in a Diamond -- WTF?
 
When I post on a certain other board, sometimes this symbol shows up between sentences.

http://www.hostpic.org/images/1302230655190096.jpg

Even when I edit the post and remove them, the little suckers come right back. Does anyone know what they are and how to stop them from appearing?

CorporalCaptain February 23 2013 02:37 AM

Re: Question Mark in a Diamond -- WTF?
 
Maybe this will help?

http://en.wikipedia.org/wiki/Unicode...ment_character

scotpens February 23 2013 03:36 AM

Re: Question Mark in a Diamond -- WTF?
 
Quote:

CorporalCaptain wrote: (Post 7719049)

Well . . . not really. The Wiki article doesn't tell me why the character is showing up instead of a space, or how to get rid of it. Frankly, technical talk about text coding is Turkish to me.

CorporalCaptain February 23 2013 05:23 AM

Re: Question Mark in a Diamond -- WTF?
 
Sorry about that. :(

The reality is that it's impossible to provide specific diagnosis without particulars (which site, what are you doing exactly, etc.); I would suggest contacting the admins of the site in question.

What jumps out at me immediately in the link I provided, that could potentially be helpful, is:

Quote:

that Wikipedia article wrote:
The replacement character ... often a black diamond with a white question mark ... is used to indicate problems when a system is not able to render a stream of data to a correct symbol. It is most commonly seen when a font does not contain a character

It goes on to say that such situations might arise because of data incompatibilities.

One thing to check is, does your text contain any "special" symbols, such as accents, smilies, Arabic, etc.? If so, then that could have something to do with it. If not, then perhaps there is a bug on the site. Between sentences is a toughie for me. If it were at the end of lines, that would be more suggestive to me.

Either way, I'd contact the admins directly. Or, open a thread on the site itself about it, because other users using that site may have experienced the same problem.

Sorry, that's all I've got. :(

Maybe someone else has more...

Timelord Victorious February 23 2013 06:35 PM

Re: Question Mark in a Diamond -- WTF?
 
Awww... I came here actually looking for a some kind of question mark formed anomaly inside an actual diamond. :lol:

scotpens February 23 2013 09:06 PM

Re: Question Mark in a Diamond -- WTF?
 
Quote:

CorporalCaptain wrote: (Post 7719466)
. . . One thing to check is, does your text contain any "special" symbols, such as accents, smilies, Arabic, etc.? If so, then that could have something to do with it. If not, then perhaps there is a bug on the site.

It's been happening when I post on the Classic Horror Film Board. I've noticed that the character shows up when I embed YouTube videos in my posts.


All times are GMT +1. The time now is 09:52 PM.

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
FireFox 2+ or Internet Explorer 7+ highly recommended.